Monday 17 August 2015

Bytelandian Gold Coins

Standard
In Byteland they have a very strange monetary system. Each Bytelandian gold coin has an integer number written on it. A coin n can be exchanged in a bank into three coins: n/2, n/3 and n/4. But these numbers are all rounded down (the banks have to make a profit).
You can also sell Bytelandian coins for American dollars. The exchange rate is 1:1. But you can not buy Bytelandian coins. You have one gold coin. What is the maximum amount of American dollars you can get for it?
Input The input will contain several test cases (not more than 10). Each testcase is a single line with a number n, 0 <= n <= 1 000 000 000. It is the number written on your coin.
Output For each test case output a single line, containing the maximum amount of American dollars you can make.
Explanation You can change 12 into 6, 4 and 3, and then change these into $6+$4+$3 = $13. If you try changing the coin 2 into 3 smaller coins, you will get 1, 0 and 0, and later you can get no more than $1 out of them. It is better just to change the 2 coin directly into $2.

Sample Input
12
2

Sample Output
13
2


Time Limit: 9 sec(s) for all input files combined.
Memory Limit: 256 MB
Source Limit: 1024 KB 
 
 
Code :
 
/ * uncomment this if you want to read input.
import java.io.BufferedReader;
import java.io.InputStreamReader;
*/
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.HashMap;
import java.util.Map;

public class Test1 {

    static Map<Long, Long> n = new HashMap<Long, Long>();

    public static void main(String[] args) throws Exception {

        BufferedReader in = new BufferedReader(new InputStreamReader(System.in));
        String s = null;

        while (true) {
            s = in.readLine();
            if (s == null)
                return;
            Long x = count(Long.parseLong(s));
            System.out.println(x);
        }
    }

    private static Long count(Long x) {

        if (x == 0 || x == 1)
            return x;
        if (n.containsKey(x))
            return n.get(x);

        Long y = Math.max(x, count(x / 2) + count(x / 3) + count(x / 4));
        n.put(x, y);
        return y;
    }

0 comments:

Post a Comment